Bug in Splash

I thought this was a problem with our site settings, but moving over to another server, the problem persisted. I just visited the Dolphin Demo and discovered there's actually a bug in the Splash.

To see what I mean, try this:

  1. Set the splash code block to non HTML.
  2. Highlight the code and cut it.
  3. Save.
  4. Uncheck Hide for logged On Users

(I then went to the home page to ensure the splash was missing and it was.)

  1. Return to the Splash code section.
  2. Paste the code.
  3. Save.
  4. Return to the Home Page.

The splash has been destroyed.

Quote · 19 Jun 2019

 

Paste the code.

 What software are you using to cut and paste with?

ManOfTeal.COM a Proud UNA site, four years running strong!
Quote · 19 Jun 2019

I confirm this bug.  Even turning the HTML editor back on, clicking source code and clearing everything out and pasting back in the clean html code, clicking save you have the /r/n showing up.  I thought maybe the new tinymce but I think the issue is when it is actually written to the database.  I can't access the demo database but see if you edit the database contents for the splash if it returns to normal.

Geeks, making the world a better place
Quote · 19 Jun 2019

 

What software are you using to cut and paste with?

I find that an odd question. Can you actually purchase software to cut and paste?

I've always use the facilities supplied with Windows (Ctrl X - Ctrl V). It works like a charm and has been for the past 20 years or more.

Quote · 20 Jun 2019

 

I find that an odd question. Can you actually purchase software to cut and paste?

 If you want to purchase something but I don't think I said anything close to that; my post is trying to be helpful. How do I know you how much experience you have.

My concern is if others here don't know, using something like Wordpad instead of Notepad makes all the difference when editing HTML or code.

 I recommend Notepad++, as I was recommended this software by a programmer to ease the work, is an open-source editor that is a bit more tailored to coding than just a text editor is what I was going to suggest but I think you're doing fine with notepad. 

 

Take note though for something that is free.

Notepad++ also includes syntax highlighting and other features for programmers working with source code.


ManOfTeal.COM a Proud UNA site, four years running strong!
Quote · 20 Jun 2019

I use Notepad++ and have done so for years, however I can't see how that would, or would not affect my original post and the discussion seems to be complicating things.

When I went to the demo site I used my Browser, not Notebook++ or Microsoft Word to cut and paste the code, thus when I removed and replaced the html, I did so with Windows universal command Ctrl X What saves the exact code into the Windows Clipboard and doesn't introduce any formatting. When I pasted it back using Ctrl V, I did nothing more that return the code precisely the way it was originally.

I have the feeling you may think that I pasted the code to Microsoft Word or something first, but my post doesn't mention that. 

Several years ago, one had to use Windows Notebook, or a public domain program to write HTML because Wordpad introduced formatting.  About three years ago, (possibly Win7) Wordpad saw massive changes and it seems you can now use it to look at, or even write code provided you don't format anything. Unformatted RTF files seem to have an identical structure to TXT files and that's saved my skin a few times.

The issue is ths - There seems to be a bug. @Geek_Girl agrees and you're welcome to test my theory and let me know if you find everything normal. I would be interested to learn what you find.

Quote · 20 Jun 2019

I do have a test site set up with 7.4.2 installed.  I will do some more investigating to see what is happening.  The problem is that we don't have active development with Dolphin any longer; so who knows when, or even if, Boonex will even address bugs we find.

Geeks, making the world a better place
Quote · 20 Jun 2019

Boonex is going to have to go though dolphin and evaluate there use of their process_db_input function.

Things have changed since they switched from php mysql database functions to PDO database functions. They are using the PDO prepare function when writing to the database. This should prevent the need to escape special characters as it was done before. In this case the escaping of the splash code is not needed.

So do this.

Edit the file administration\basic_settings.php

Look for this at about line 41

setParam('splash_code',  process_db_input($_POST['code'], CH_TAGS_VALIDATE));

Change it to this

setParam('splash_code',  clear_xss($_POST['code']));

That should fix it.



https://www.deanbassett.com
Quote · 20 Jun 2019

That works perfectly Deano.

Thanks for jumping on to it so quickly.

Also thanks to the others for their input.

Regards John

Quote · 20 Jun 2019

 

Boonex is going to have to go though dolphin and evaluate there use of their process_db_input function.

I don't see Boonex doing any real work on Dolphin.  We will need to document all the problems we are coming across in a central location; along with solutions.  That way those of us still committed to Dolphin can simply point others to the repository of bugs and fixes.  This repository needs to be off of Boonex because we can't be certain what the future holds.

Geeks, making the world a better place
Quote · 20 Jun 2019

 

Boonex muss Delphine durchsuchen und dort die Verwendung ihrer process_db_input-Funktion auswerten.

Die Dinge, die Sie geändert haben, sind PHP-MySQL-Datenbankfunktionen zu PDO-Datenbankfunktionen geworden. Sie verwenden beim Schreiben in die Datenbank die PDO-Vorbereitungsfunktion. Dies sollte verhindern, dass Sonderzeichen wie zuvor maskiert werden müssen. In diesem Fall muss der Splash-Code nicht maskiert werden.

Mach das auch.

Bearbeiten Sie die Datei administration \ basic_settings.php.

Suchen Sie dazu in ungefähr Zeile 41 nach

setParam ('splash_code', process_db_input ($ _ POST ['code'], CH_TAGS_VALIDATE)).

Ändern Sie es in diesen

setParam ('splash_code', clear_xss ($ _ POST ['code'

Das sollte es beheben.



 I have tested the code of Deno on Dolphin 7.4.2

my https://my-site.net/administration/basic_settings.php

Now displays a blank page.

Great result.

Quote · 18 Oct 2019

Hello Jurgen!

 

The blank screen means that this page has the PHP error which can be tracked in the error log of your server.

Quote · 21 Oct 2019

Hi deano92964,

My splash got messed up after I updated the text. Then I found your post. Your fix solved my problem. Hopefully, the Boonex team will add your fix into the next Dolphin release.

Thanks a lot for your contribution and help.

Quote · 25 Oct 2019

Thanks Deano. Worked for me also

Jeremy
Quote · 26 Oct 2019
 
 
Below is the legacy version of the Boonex site, maintained for Dolphin.Pro 7.x support.
The new Dolphin solution is powered by UNA Community Management System.