Upgrading from 6.1.4 to D7

Profesize posted 26th of October 2009 in Community Voice. 19 comments.

Hey Mr Boonex! Any word yet on this subject? Will this be available or will we have to upgrade to 6.1.5 and 6.1.6 before going to D7?

Am keeping my fingers crossed that this will be available. I am sure many others are too.

Prof

 

Just like Boonex...am proudly Australian too!

 
Comments
·Oldest
·Top
Please login to post a comment.
mydatery
Okay, because you failed to upgrade to 6.1.5 & .6 Boonex should take the time to create a special upgrade package to go straight to D7? Wow, that's such a great idea.

After all, why should Boonex leave you out? After all, you've kept up with everything so well so far and done your part to keep your Dolphin site secure.


My suggestion to Boonex, let him keep dreaming and don't waste your time on this. It's going to be enough work lining up D 6.1.6 to 7 without creating a special see more version to get those who ignored the advice to upgrade from whatever verson their on.
Profesize
Wow! I bet you are fun to hang out with at a party!

One thing I have learnt while using this software is to upgrade as few times as possible cause it always ends up as a palava.

I know from other peoples' posts that they too have stayed on 6.1.4, maybe for similar reasons or maybe something else. Both Caltrade and Zarcon have mentioned the same thing about this particular update script.

You should really stop and think before you talk. It might save you a lot of grief.
bpowers84
Some users didn't upgrade to D 6.1.6 and I wish I hadn't as it broke my site more than anything else, this person is asking a valid question as some software developers do indeed do this, however you could have simply said that you should upgrade your site to D 6.1.6 before Boonex releases a software upgrade path for D7 and it could have been done in a positive way.

Can someone tell me why this AS* is allowed to continue to be so rude and arrogant around here and why his privileges haven't been see more removed from Unity and we all know I am referencing the rude and arrogant "MyDatery".
mistertunechat
I dont get it either mydatery has a snide or rude comment everytime he doesnt agree with someone. Its incredible this guys priviledges arent revoked or he doesnt receive some sort of warning. People dont come on here to get attacked or to be talked down to, from the likes of people like mydatery. Its apparent people are beyond fed up with him by his over abundance of negative comments now. People like him hurt business more then they help just from their attitude. Even if he does say something see more worth mentioning its usually overshadowed by his rude and arrogant remarks to everyone else. Boonex please do something about negative and even abusive remarks from all members, so this can be a pleasent discussion from everyone, without people having to worry about abuse from other members.
tyke
There is a reason why people dont want to update to 6.1.6 and thats because it doesn't work properly, i myself wish i had stayed with 6.1.4.
There is a solution though when the RC comes out, and that is to do all the upgrading then.
From 6.1.4, 6.1.5 6.1.6 and then dolphin 7. Its a bit long winded but it can be done in a few hours.

regards

tyke
Profesize
Thanks tyke. It may just come to that.
danielmarseille
I made the updates 6.1.4 to 6.1.6

dolphin 6.1.6 works fine
Zarcon
I didn't upgrade to 6.1.5 or 6.1.6 because I have a heavily modded 6.1.4 and it works fine. I did not see the benefit of upgrading to either of those at the time of their release. Also upgrading would have caused me to lose all my mods or re-do the 27+ mods on the site, which I didn't feel like doing.

I am not gonna say anything about Mydatery because he tends to crack me up periodically, but I will have to say that there are still quite a few folks on the 6.1.4 platform.

Profesize, When I see more posted the question to Boonex, this is what they had to say about that:

unoboonex
Well, the plan is to have 2-3 developers sit with both 7.0 and the 6.1.4 and work on the upgrade package and do as much as we can do within a a week or so. Hopefully it would migrate most of the data.

Worse case scenario is we will have to do the 3 part upgrade to get to D7 (6.1.5, 6.1.6, then D7). Since D7 has most all of the features I have modded for, I will not mind doing that. Not really looking forward to it, but hey.. I am willing to see what happens when the RC comes out.
emc6250
I have a 6.1.4 site with a few mods - tried to upgrade to 6.1.6 and had so many problems, I just went back to 6.1.4
danielmarseille
to help you there are files comparison

http://www.boonex.com/trac/dolphin/wiki/TitleIndex
mydatery
@ Zarcon, I run 6.1.6 domains right now, that we're developed under 6.1.4 software initially. When it came time to upgrade, I skipped the 6.1.5 upgrade initially and waited for the 6.1.6 and did both at the same time.

What I discovered, by doing file comparisons to find the exact changes (as danielmarseille has given the link to) that it all went pretty seamlessly. I still ended up with items like the Ray My Presence Friends bug, but we all got that little on and it was an easy fix for it. see more In the end, my mods actually worked better as the 6.1.6 version actually cleaned up a lot of bad code that 6 1 4 had in it.


Don't get me wrong, it took almost a week with all the mods to make this happen, but it was definitely worth it. I'm over 150 mods now, a large part of those are fully custom items for my sites only and they help me deliver what I need to deliver to customers, and I'm finding it even easier to install these mods and run into less problems now than I ever have.

As far as those who are on 6.1.4 still and asking Boonex to do the work for you to make a direct transition, I don't agree with that. They've already done the work to get you there and it's solid. While it's understandable that you may not want to spend days bringing your site up to 6 1 6 standards to just have to go straight into making a D7 transition, it's also not fair to ask Boonex to rewrite everything again just for those who chose to not do it.

Now, for my funtime:

@ Profesize: First it causes me no grief whatsoever. As far as the party goes, you'll never know, you couldn't afford the shoes it would take to walk up the steps, let alone in the door of any party I'm at.

@ BPowers84: Look at my post count, the amount of development work I do, the number of development only domains I own and how much I do for the community and you'll begin to get the picture. Amazingly, I also will rarely swear in a post since I became the kinder, gentler, nicer, softer, new, improved MyDatery. Perhaps you should take a look at what you do to help people out and then you might have less time to look at what I'm doing around here. Now, we both know that if you stick an asterisk in it's still the same thing as saying the word, just demonstrates a lack of courage on the part of the writer who uses that asterisk.
Zarcon
I know, I can honestly say I am being lazy to a degree. What I am thinking of doing is since D7 has most of the mods "built-in" already (privacy, albums, member activities (Spy)) and the migration just does profiles, photo, videos, etc. I may just run both upgrades back-to-back and then migrate to D7. There is really only 1 mod I am taking with me to D7 and I am trying extremely hard not to upload all 2.4 Gigs of it :)
mistertunechat
Once again mydatery with more condescending almost god like remarks. This guy is ridiculous, you should seriously not allow abusive posts. This is starting to feel like some sort of yahoo forum, because of people like him that constantly brings the mood down. Again I am not disputing mydatery does not know what he is talking about, its the way he is going about conveying his message. Its amazing this guy is even able to go in public with his poor attitude.
Profesize
Wow again mydatery! I take back what I said about you and parties. You really do know how to have a FUNTIME!

lol
CALTRADE
Thanks for the post Profesize. I completely agree. In fact, I think that 6.1.5 and 6.1.6 upgrades were a mistake since 6.1.4 was stable and well understood. In any event, the vast majority of members never did these upgrades so this would be a nice thing to do for the user community here.
LightWolf
A heart so hard on the outside, a soul so empty on the inside...Is sad actually.
tomakali
@ all
{listening and LOL}
ibiza
if i install d7 can i move my database from d616 as a backup
 
 
Below is the legacy version of the Boonex site, maintained for Dolphin.Pro 7.x support.
The new Dolphin solution is powered by UNA Community Management System.
PET:0.13082504272461